Insights

Home / Insights / QuickBooks Security Update Needed for Uninterrupted Services Download PDF

Smart Entrepreneurial Services Talk to an advisor: (816) 743-7700

QuickBooks Security Update Needed for Uninterrupted Services

June 4, 2018

Businesses who use QuickBooks Desktop 2015 or later need to perform an update immediately to meet specific system requirements. The update provides greater security and stability with TLS 1.2, an internet security protocol.

Those using QuickBooks who fail to meet the new requirements will notice an impact to the following services:

  • Connected services such as Payroll, Payments, Online Banking, Etc.
  • QuickBooks Desktop activation on a new computer
  • Password reset tool
  • Services that require Intuit account credentials such as My apps, secure webmail, contributed reports, etc.
  • Intuit Data Protect (IDP)
  • Ordering Checks and Supplies

What You Need to Do

QuickBooks recommends performing the steps below:

  1. Make sure the QuickBooks Desktop version you are using is updated to the latest release.
  2. Run the TLS 1.2 Readiness tool from this QuickBooks article on the computer where QuickBooks is installed to confirm your system readiness for TLS 1.2.
  3. If the TLS 1.2 Readiness tool indicates failure, you should review the details here to take the necessary steps.

For more information check out this QuickBooks article. Or if you have questions about the update or using QuickBooks for your business contact your MarksNelson Entrepreneurial Services professional at 816-743-7700.

 

About THE AUTHOR
At MarksNelson, we pride ourselves on our commitment to innovation and technology. This fuels our professionals' drive to work with you, not for you - bringing comprehensive and innovative solutions to the conversation and helping remove uncertainty from the outcome. >>> READ MORE
Questions for MarksNelson?
Want More Information Like This?

MarksNelson
WHITEPAPER

5 Steps to Building Your Technology Roadmap

DOWNLOAD GUIDE